commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Commented: (LANG-514) CharRange constructor is hard to read
Date Sun, 09 Aug 2009 02:55:14 GMT

    [ https://issues.apache.org/jira/browse/LANG-514?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12741017#action_12741017
] 

Henri Yandell commented on LANG-514:
------------------------------------

Looks good - thanks Vincent.

I wonder if the constructor should become private. I'm also wondering if the other constructor
should go away and we end up with:

CharRange.is(char)
CharRange.isNot(char)
CharRange.isIn(char, char)
CharRange.isNotIn(char, char)

Anyone with thoughts on that?

> CharRange constructor is hard to read
> -------------------------------------
>
>                 Key: LANG-514
>                 URL: https://issues.apache.org/jira/browse/LANG-514
>             Project: Commons Lang
>          Issue Type: Improvement
>            Reporter: Henri Yandell
>             Fix For: 3.0
>
>         Attachments: LANG-514.patch
>
>
> Saying new CharRange("....", true) is a very painful way to negate the '...'. Both for
cryptic, and because you'd expect true to mean positiveness and false to imply the 'not'.
> Replace this with a static method:
> CharRange.not("....").

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message