commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary Gregory (JIRA)" <>
Subject [jira] Commented: (CODEC-86) Rename method to Base64.encodeBase64ToString()
Date Thu, 06 Aug 2009 15:55:15 GMT


Gary Gregory commented on CODEC-86:

If we do something like this, we should to check all of our APIs for naming consistency in
the case where the return type is included in the method name. Personally, it seems fine to
me the way it is now but if someone wants to change it, that's fine as long as it is done

> Rename method to Base64.encodeBase64ToString()
> ----------------------------------------------
>                 Key: CODEC-86
>                 URL:
>             Project: Commons Codec
>          Issue Type: Improvement
>    Affects Versions: 1.4
>            Reporter: Julius Davies
>            Priority: Trivial
>             Fix For: 1.4
>         Attachments: codec86.patch
> I'm having second thoughts on two method names for CODEC-59.  Here's what it currently
looks like:
> Base64.encodeBase64String(byte[] binaryData)
> Base64.encodeBase64URLSafeString(byte[] binaryData)
> (screenshot from IntelliJ 7, 15KB, 760x187)
> I'm wondering if the word "To" should be inserted there?  As in "ToString":
> Base64.encodeBase64ToString(byte[] binaryData)
> Base64.encodeBase64URLSafeToString(byte[] binaryData)
> (screenshot from IntelliJ 7, 14KB, 736x162)
> Sorry about this inane niggling.  I just thought it's either now or
> never!  Any one else have opinions about this extremely minor cosmetic
> point?

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message