commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phil Steitz (JIRA)" <>
Subject [jira] Closed: (MATH-275) MANIFEST.MF contains incorrect "Import-Package" OSGi header (makes it unusable for OSGi)
Date Sun, 14 Jun 2009 18:53:07 GMT


Phil Steitz closed MATH-275.

    Resolution: Won't Fix

Agree with Niall's analysis.  We can reopen and change if and when guidance from Felix changes.

> MANIFEST.MF contains incorrect "Import-Package" OSGi header (makes it unusable for OSGi)
> ----------------------------------------------------------------------------------------
>                 Key: MATH-275
>                 URL:
>             Project: Commons Math
>          Issue Type: Bug
>    Affects Versions: 1.2
>            Reporter: Paul Field
> The MANIFEST.MF file contains this OSGi header:
> Import-Package:,
>  org.apache.commons.math;version=1.2,
>  org.apache.commons.math.analysis;version=1.2,
>  org.apache.commons.math.complex;version=1.2,
> ...
> This header defines what the bundle requires from the OSGi runtime and so it shouldn't
include the packages defined in the bundle (i.e. all the org.apache.commons packages). I suspect
it shouldn't include the package either as I can't see
that math has a dependency on that (I could be wrong :-) ).
> The presence of this header causes the Math library to be unusable as an OSGi bundle
in Eclipse RCP development (and I suspect in any OSGI container).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message