commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Moved: (COMPRESS-79) Move DOS/Java time conversions into Zip utility class
Date Sun, 21 Jun 2009 04:38:07 GMT

     [ https://issues.apache.org/jira/browse/COMPRESS-79?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell moved SANDBOX-301 to COMPRESS-79:
-----------------------------------------------

        Key: COMPRESS-79  (was: SANDBOX-301)
    Project: Commons Compress  (was: Commons Sandbox)

> Move DOS/Java time conversions into Zip utility class
> -----------------------------------------------------
>
>                 Key: COMPRESS-79
>                 URL: https://issues.apache.org/jira/browse/COMPRESS-79
>             Project: Commons Compress
>          Issue Type: Improvement
>            Reporter: Sebb
>
> ZipFile.dosToJavaTime()
> and
> ZipArchiveOutputStream.toDosTime()
> could be moved to a common utilities package and made public.
> toDosTime() should use Calendar to agree with dosToJavaTime().
> Maybe toDosTime() should be renamed as javaToDosTime() to agree with the reverse.
> ZipFile.fromDosTime() does not appear to be used, and the protected ZipArchiveOutputStream.toDosTime()
is only used in a Test class
> There should probably also be some tests for the methods (which would be easier to do
with public methods).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message