commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CLI-178) org.apache.commons.cli.ParserTestCase: Test doesn't pass on Sun JDK 1.6.0.12, Gentoo Linux
Date Sat, 28 Mar 2009 00:30:50 GMT

     [ https://issues.apache.org/jira/browse/CLI-178?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Sebb resolved CLI-178.
----------------------

    Resolution: Invalid

The class is not supposed to be run, so it's not a bug that it causes errors.

> org.apache.commons.cli.ParserTestCase: Test doesn't pass on Sun JDK 1.6.0.12, Gentoo
Linux
> ------------------------------------------------------------------------------------------
>
>                 Key: CLI-178
>                 URL: https://issues.apache.org/jira/browse/CLI-178
>             Project: Commons CLI
>          Issue Type: Bug
>          Components: CLI-1.x
>    Affects Versions: 1.2
>         Environment: Gentoo Linux, Sun JDK 1.6.0.12
>            Reporter: Jean-Noel Rivasseau
>             Fix For: 1.3
>
>
> Hello, I was bumping the Gentoo version of commons-CLI to 1.2 and in the process tried
to run the tests. It fails at this test:
>     [junit] Testsuite: org.apache.commons.cli.ParserTestCase
>     [junit]     at sun.reflect.InstantiationExceptionConstructorAccessorImpl.newInstance(InstantiationExceptionConstructorAccessorImpl.java:30)
>     [junit]     at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>     [junit]     at junit.framework.TestSuite.createTest(TestSuite.java:54)
>     [junit]     at junit.framework.TestSuite.addTestMethod(TestSuite.java:280)
>     [junit]     at junit.framework.TestSuite.<init>(TestSuite.java:140)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:396)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:911)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:768)
>     [junit] ))
>     [junit] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0.073 sec
>     [junit] Tests run: 1, Failures: 1, Errors: 0, Time elapsed: 0.073 sec
>     [junit]
>     [junit] Testcase: warning took 0.005 sec
>     [junit]     FAILED
>     [junit] Cannot instantiate test case: testSimpleShort (java.lang.InstantiationException
>     [junit]     at sun.reflect.InstantiationExceptionConstructorAccessorImpl.newInstance(InstantiationExceptionConstructorAccessorImpl.java:30)
>     [junit]     at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>     [junit]     at junit.framework.TestSuite.createTest(TestSuite.java:54)
>     [junit]     at junit.framework.TestSuite.addTestMethod(TestSuite.java:280)
>     [junit]     at junit.framework.TestSuite.<init>(TestSuite.java:140)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.run(JUnitTestRunner.java:396)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.launch(JUnitTestRunner.java:911)
>     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:768)
>     [junit] )
>     [junit] junit.framework.AssertionFailedError: Cannot instantiate test case: testSimpleShort
(java.lang.InstantiationException
>     [junit]     at java.lang.reflect.Constructor.newInstance(Constructor.java:494)
>     [junit] )
>     [junit]
> Note that the others tests before run fine. Note that when using Maven all the tests
run fine but only because the problematic test is *NOT* run. Does that means that it should
not be run? (I used mvn ant:ant to generate an Ant buildfile as Gentoo packaging system does
not support Maven yet).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message