commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rory Winston (JIRA)" <j...@apache.org>
Subject [jira] Closed: (NET-111) [net] The telnet client is leaving the connection even after calling the disconnect properly.
Date Sun, 22 Mar 2009 19:15:50 GMT

     [ https://issues.apache.org/jira/browse/NET-111?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Rory Winston closed NET-111.
----------------------------

    Resolution: Cannot Reproduce

> [net] The telnet client is leaving the connection even after calling the disconnect properly.
> ---------------------------------------------------------------------------------------------
>
>                 Key: NET-111
>                 URL: https://issues.apache.org/jira/browse/NET-111
>             Project: Commons Net
>          Issue Type: Bug
>    Affects Versions: 1.1
>         Environment: Operating System: Linux
> Platform: Other
>            Reporter: Krishnarao
>
> The TelnetClient module of commons/net is leaving the connection on the server 
> open even after the disconnect() is called properly. This is happening only on 
> Linux but not on solaris. I am using redhat Linux 8.0 on Intel xeon. Kernel 
> version 2.4.20-20.8smp.
> Temporarly we are sending exit to the telnet shell, which is clearing the 
> connection, but causing the null pointer exception.
> ==========================
> login: java.lang.NullPointerException
>         at java.io.BufferedInputStream.read(BufferedInputStream.java:208)
>         at java.io.FilterInputStream.read(FilterInputStream.java:69)
>         at java.io.PushbackInputStream.read(PushbackInputStream.java:123)
>         at org.apache.commons.net.io.FromNetASCIIInputStream.__read
> (FromNetASCIIInputStream.java:114)
>         at org.apache.commons.net.io.FromNetASCIIInputStream.read
> (FromNetASCIIInputStream.java:209)
>         at java.io.BufferedInputStream.fill(BufferedInputStream.java:186)
>         at java.io.BufferedInputStream.read(BufferedInputStream.java:204)
>         at org.apache.commons.net.telnet.TelnetInputStream.__read
> (TelnetInputStream.java:140)
>         at org.apache.commons.net.telnet.TelnetInputStream.run
> (TelnetInputStream.java:464)
>         at java.lang.Thread.run(Thread.java:484)
> =================================================================
> Please help on this. This problem is there in 1.0.0. Recenly we downloaded 
> 1.1.0. this new version also has the same problem on linux. I am not sure, 
> this bug is related to linux or commons-net.
> Thank you for your help
> Krishnarao.
> knandipati@s-square.net

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message