commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sebb (JIRA)" <j...@apache.org>
Subject [jira] Created: (SANDBOX-301) Move DOS/Java time conversions into Zip utility class
Date Sat, 14 Mar 2009 01:46:51 GMT
Move DOS/Java time conversions into Zip utility class
-----------------------------------------------------

                 Key: SANDBOX-301
                 URL: https://issues.apache.org/jira/browse/SANDBOX-301
             Project: Commons Sandbox
          Issue Type: Improvement
            Reporter: Sebb


ZipFile.dosToJavaTime()
and
ZipArchiveOutputStream.toDosTime()

could be moved to a common utilities package and made public.

toDosTime() should use Calendar to agree with dosToJavaTime().

Maybe toDosTime() should be renamed as javaToDosTime() to agree with the reverse.

ZipFile.fromDosTime() does not appear to be used, and the protected ZipArchiveOutputStream.toDosTime()
is only used in a Test class

There should probably also be some tests for the methods (which would be easier to do with
public methods).

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message