commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@apache.org>
Subject [jira] Issue Comment Edited: (EXEC-27) Rename EnvironmentUtil to EnvironmentUtils
Date Fri, 14 Nov 2008 10:28:44 GMT

    [ https://issues.apache.org/jira/browse/EXEC-27?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12647563#action_12647563
] 

bentmann edited comment on EXEC-27 at 11/14/08 2:27 AM:
-----------------------------------------------------------------

bq. nd I'm not really willing to break backward compatibility 
Backward compat with what? The [project status|http://commons.apache.org/exec/] says "The
code is unreleased."

bq. Regarding separation of public class and internal representation
Just let me explain why I feel it's worth/important to think about that. Over at Maven, they
basically made everything public. Then some heavy redesign was due and in the effort to keep
some backward-compat, they wonder why users are using so many of their internal but public
classes... I'm admittedly naive, but there is a reason why Java provides different accessibility
modes. The smaller the public/protected API, the easier to maintain it.

bq. I'm not too happy with structure [...] but I try to stick closely to the original ANT
code simply because it is mature and known to work.
I don't see how refactoring, i.e. renaming/moving classes, can affect the stability. What
better chance to clean up the API is there than before a library's first release? Anyway,
it's your baby...

      was (Author: bentmann):
    bq. nd I'm not really willing to break backward compatibility 
Backward compat with what? The [project status|http://commons.apache.org/exec/] says "The
code is unreleased."

bq. I'm not too happy with structure [...] but I try to stick closely to the original ANT
code simply because it is mature and known to work.
I don't see how refactoring, i.e. renaming/moving classes, can affect the stability. What
better chance to clean up the API is there than before a library's first release? Anyway,
it's your baby...
  
> Rename EnvironmentUtil to EnvironmentUtils
> ------------------------------------------
>
>                 Key: EXEC-27
>                 URL: https://issues.apache.org/jira/browse/EXEC-27
>             Project: Commons Exec
>          Issue Type: Wish
>    Affects Versions: 1.0
>            Reporter: Benjamin Bentmann
>            Assignee: Siegfried Goeschl
>            Priority: Trivial
>         Attachments: EXEC-27.patch
>
>
> Utility classes from exec:
> - {{DebugUtils}}
> - {{MapUtils}}
> - {{StringUtils}}
> - {{EnvironmentUtil}}
> Note that {{EnvironmentUtil}} is the only one using singular form of utility. To make
the API consistent, both within exec and compared with other commons libs like collections
and lang, I suggest to rename the class to {{EnvironmentUtils}}.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message