commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Bentmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (EXEC-27) Rename EnvironmentUtil to EnvironmentUtils
Date Sat, 26 Jul 2008 11:09:31 GMT

    [ https://issues.apache.org/jira/browse/EXEC-27?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12617157#action_12617157
] 

Benjamin Bentmann commented on EXEC-27:
---------------------------------------

Related note: The classes {{DefaultProcessingEnvironment}} and {{OpenVmsProcessingEnvironment}}
are according to their API docs "helper classes". If these are not meant to be helpers for
the client but rather implementation helpers, maybe add a warning to the javadoc or preferrably
reduce their visibility to package/default to exclude them from the public API?

> Rename EnvironmentUtil to EnvironmentUtils
> ------------------------------------------
>
>                 Key: EXEC-27
>                 URL: https://issues.apache.org/jira/browse/EXEC-27
>             Project: Commons Exec
>          Issue Type: Wish
>    Affects Versions: 1.0
>            Reporter: Benjamin Bentmann
>            Priority: Trivial
>         Attachments: EXEC-27.patch
>
>
> Utility classes from exec:
> - {{DebugUtils}}
> - {{MapUtils}}
> - {{StringUtils}}
> - {{EnvironmentUtil}}
> Note that {{EnvironmentUtil}} is the only one using singular form of utility. To make
the API consistent, both within exec and compared with other commons libs like collections
and lang, I suggest to rename the class to {{EnvironmentUtils}}.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message