commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henri Yandell (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Mon, 09 Jun 2008 07:09:45 GMT

     [ https://issues.apache.org/jira/browse/LANG-420?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henri Yandell updated LANG-420:
-------------------------------

         Fix Version/s: LangTwo 1.0
    Remaining Estimate:     (was: 0.5h)
     Original Estimate:     (was: 0.5h)

Assigning to LangTwo; seems unlikely we'd want to adjust this for 3.0.

> Rename ObjectUtils.toString() to asString().
> --------------------------------------------
>
>                 Key: LANG-420
>                 URL: https://issues.apache.org/jira/browse/LANG-420
>             Project: Commons Lang
>          Issue Type: Improvement
>    Affects Versions: 2.3
>            Reporter: Stephen Kestle
>            Priority: Trivial
>             Fix For: LangTwo 1.0
>
>
> With Java 5 static method inlining, methods do not require class qualifying *unless*
the class already has the method.
> For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has
a toString() method.  
> It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()
> Note that this DOES NOT need a java 5 version of lang.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message