commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Kestle (JIRA)" <>
Subject [jira] Created: (LANG-420) Rename ObjectUtils.toString() to asString().
Date Fri, 28 Mar 2008 02:36:24 GMT
Rename ObjectUtils.toString() to asString().

                 Key: LANG-420
             Project: Commons Lang
          Issue Type: Improvement
    Affects Versions: 2.3
            Reporter: Stephen Kestle
            Priority: Trivial

With Java 5 static method inlining, methods do not require class qualifying *unless* the class
already has the method.

For this reason, ObjectUtlis.toString() cannot be inlined to toString(), as Object has a toString()

It would be nice for it to have a name that could be statically imported, such as asString.
 This would follow the naming convention of Arrays.asList()

Note that this DOES NOT need a java 5 version of lang.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message