commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Niall Pemberton (JIRA)" <j...@apache.org>
Subject [jira] Commented: (VALIDATOR-230) Enum validator
Date Sat, 03 Nov 2007 07:01:50 GMT

    [ https://issues.apache.org/jira/browse/VALIDATOR-230?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#action_12539887
] 

Niall Pemberton commented on VALIDATOR-230:
-------------------------------------------

My aim for the "routines" package was all the actual validation routines (i.e. no "framework")
and with no dependencies outside the package. The thinking there was that we could possibly
package up a "routines" jar with zero dependencies. I'm reluctant to go against that without
a compelling case and IMO Apache Enums (presumably you mean Commons Lang's enum?) became yesterdays
solution when JDK 1.5 arrived.

On JDK 1.5 enums - Validator only just moved to a minimum dependency of JDK 1.4 (for Validator
1.4) - I'm OK with moving to JDK 1.5 for validator2, but I'd prefer Validator 1.4 was released
based on JDK 1.4 (given that the last 1.3.1 release had a min. of JDK 1.3).

> Enum validator
> --------------
>
>                 Key: VALIDATOR-230
>                 URL: https://issues.apache.org/jira/browse/VALIDATOR-230
>             Project: Commons Validator
>          Issue Type: New Feature
>            Reporter: Paul Benedict
>             Fix For: Validator2
>
>
> An "enum" validator which validates a value is member of an Commons Enum type or JDK5
type. Attachment forthcoming.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message