commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Speakmon (JIRA)" <>
Subject [jira] Updated: (LANG-377) Perhaps add containsAny() methods?
Date Fri, 16 Nov 2007 19:45:43 GMT


Ben Speakmon updated LANG-377:

    Priority: Minor  (was: Major)

Pushing down to minor priority, which I assume is uncontroversial; please correct me if necessary.

-0 on inclusion from me simply because I don't generally see the point in adding inverses
of existing methods; it's just API clutter.

> Perhaps add containsAny() methods?
> ----------------------------------
>                 Key: LANG-377
>                 URL:
>             Project: Commons Lang
>          Issue Type: Improvement
>            Reporter: Sebb
>            Priority: Minor
>             Fix For: 2.4
> Might be useful to have containsAny(String, char[]) and containsAny(String, String) methods.
> They would be the inverse of containsNone() (so are not strictly necessary), but to my
>     containsAny(str,"abc") 
> looks nicer and is easier to read than the double negative
>    !containsNone(str,"abc")

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message