commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bjorn Townsend (JIRA)" <j...@apache.org>
Subject [jira] Updated: (LANG-377) Perhaps add containsAny() methods?
Date Sun, 18 Nov 2007 00:01:43 GMT

     [ https://issues.apache.org/jira/browse/LANG-377?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Bjorn Townsend updated LANG-377:
--------------------------------

    Attachment: LANG-377-test.patch

Here's a test for this, for completeness' sake. It's just the inverse of the containsNone
test.

> Perhaps add containsAny() methods?
> ----------------------------------
>
>                 Key: LANG-377
>                 URL: https://issues.apache.org/jira/browse/LANG-377
>             Project: Commons Lang
>          Issue Type: Improvement
>            Reporter: Sebb
>            Assignee: Niall Pemberton
>            Priority: Minor
>             Fix For: 2.4
>
>         Attachments: LANG-377-test.patch
>
>
> Might be useful to have containsAny(String, char[]) and containsAny(String, String) methods.
> They would be the inverse of containsNone() (so are not strictly necessary), but to my
eyes
>     containsAny(str,"abc") 
> looks nicer and is easier to read than the double negative
>    !containsNone(str,"abc")

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message