commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Leung (JIRA)" <j...@apache.org>
Subject [jira] Created: (BEANUTILS-294) BeanUtilsBean.setProperty() does not support nested map
Date Mon, 03 Sep 2007 15:56:59 GMT
BeanUtilsBean.setProperty() does not support nested map
-------------------------------------------------------

                 Key: BEANUTILS-294
                 URL: https://issues.apache.org/jira/browse/BEANUTILS-294
             Project: Commons BeanUtils
          Issue Type: Bug
          Components: Bean / Property Utils
    Affects Versions: 1.8.0-BETA
            Reporter: Stephen Leung
            Priority: Critical


I tried to call BeanUtilsBean.setProperty() with a DynaActionForm as the "bean" and "someMap(x)(y)"
as the "name". In BeanUtilsBean.setProperty(), after the while loop at line 900, target became
"null" and name became = "(y)". And consequently IllegalArgumentException is thrown at line
930 when setProperty() tried to getPropertyDescriptor() of a null bean. Specifically, the
following is the stack trace. Could somebody look into it?

Thanks.

java.lang.IllegalArgumentException: No bean specified
     at org.apache.common.beanutils.PropertyUtilsBean.getPropertyDescriptor(PropertyUtilsBean.java:871)
     at org.apache.commons.beanutils.BeanUtilsBean.setProperty(BeanUtilsBean.java:930)
     at org.apache.commons.beanutils.BeanUtilsBean.populate(BeanUtilsBean.java:829)
     at org.apache.commons.beanutils.BeanUtils.populate(BeanUtilsBean.java:433)
     at org.apache.struts.util.RequestUtils.pouplate(RequestUtils.java:467)
    ......





-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message