commons-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Oliver Heger (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (CONFIGURATION-291) addNodes() doesn't trigger auto saving
Date Sat, 11 Aug 2007 14:53:43 GMT

     [ https://issues.apache.org/jira/browse/CONFIGURATION-291?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Oliver Heger resolved CONFIGURATION-291.
----------------------------------------

    Resolution: Fixed

A fix was committed. Thanks for spotting this.

> addNodes() doesn't trigger auto saving
> --------------------------------------
>
>                 Key: CONFIGURATION-291
>                 URL: https://issues.apache.org/jira/browse/CONFIGURATION-291
>             Project: Commons Configuration
>          Issue Type: Bug
>    Affects Versions: 1.4
>         Environment: I am using Nightly build dated July 19, 2007
>            Reporter: irina fridkina
>            Assignee: Oliver Heger
>             Fix For: 1.5
>
>
> When I add nodes the XMLConfiguration with autoSave enabled the file doen't change to
reflect new nodes. Here is an example
> XMLConfiguration config = new XMLConfiguration("c:\\conf.xml"); 
> config.setAutoSave(true) ;
> ConfigurationNode childNode = new HierarchicalConfiguration.Node("ChildNodeName","ChildNodeValue");
> List nodes = new ArrayList();
> nodes.add(childNode);
> config.addNodes(null,nodes);
> config.xml didn't change to include child node.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message