commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gary Gregory <garydgreg...@gmail.com>
Subject Re: [COLLECTIONS] Test failures on Windows
Date Wed, 11 Oct 2017 22:41:02 GMT
Works like a charm for me on Windows 10 and

Apache Maven 3.5.0 (ff8f5e7444045639af65f6095c62210b5713f426;
2017-04-03T13:39:06-06:00)
Maven home: C:\Java\apache-maven-3.5.0\bin\..
Java version: 1.8.0_144, vendor: Oracle Corporation
Java home: C:\Program Files\Java\jdk1.8.0_144\jre
Default locale: en_US, platform encoding: Cp1252
OS name: "windows 10", version: "10.0", arch: "amd64", family: "windows"

Committed!
:-)
Gary

On Wed, Oct 11, 2017 at 5:06 AM, Andreas Kuhtz <andreas.kuhtz@gmail.com>
wrote:

> Hi,
>
> Tested with the changes of your PR multiple times with Win7-64bit and JDK7
> and JDK8 without any issues.
>
> Cheers
> Andreas
>
>
>
> 2017-10-11 10:03 GMT+02:00 Bruno P. Kinoshita <
> brunodepaulak@yahoo.com.br.invalid>:
>
> > Done.
> > https://github.com/apache/commons-collections/pull/28
> >
> > Tested on Windows 10 + JDK8, and Ubuntu LTS + JDK8.
> > Would be good if someone else with a Windows version could try it too,
> and
> > if others could have a look at the suggested solution in the pull request
> > to see if there's a better way of doing it.
> > CheersBruno
> >       From: Bruno P. Kinoshita <brunodepaulak@yahoo.com.br.INVALID>
> >  To: Commons Developers List <dev@commons.apache.org>
> >  Sent: Wednesday, 11 October 2017 12:43 PM
> >  Subject: Re: [COLLECTIONS] Test failures on Windows
> >
> > Still investigating. Trying to isolate the problem
> > https://github.com/kinow/commons-collections/tree/COLLECTIONS-661-1
> >
> > No luck so far. I have an environment where it happens over 90% of the
> > time. Tried debugging a few times, adding some sysout statements to see
> if
> > there was anything suspect... yesterday enabled findbugs in test to look
> > for any issue in the test classes. Nothing yet.
> >
> > Bruno
> >
> >       From: Gary Gregory <garydgregory@gmail.com>
> >  To: Commons Developers List <dev@commons.apache.org>
> >  Sent: Wednesday, 11 October 2017 12:13 PM
> >  Subject: Re: [COLLECTIONS] Test failures on Windows
> >
> > Where are we on this one?
> >
> > Gary
> >
> > On Mon, Oct 2, 2017 at 3:34 AM, Pascal Schumacher <
> > pascalschumacher@gmx.net>
> > wrote:
> >
> > > Looks like the random failures are not limited to window. The travis
> > build
> > > (ubuntu), just failed with 44 failures, e.g.
> > >
> > > AbstractMultiValuedMapTest$TestMultiValuedMapAsMap>AbstractM
> > > apTest.testMapToString:745->AbstractMapTest.verify:1947->
> > AbstractMapTest.verifyMap:1958
> > > hashCodes should be the same expected:<205172737> but was:<9372706>
> > >
> > >
> > > see: https://travis-ci.org/apache/commons-collections/jobs/282169803
> > >
> > >
> > > Am 28.09.2017 um 20:23 schrieb Andreas Kuhtz:
> > >
> > >> Hi,
> > >>
> > >> 2017-09-27 22:28 GMT+02:00 Bruno P. Kinoshita <kinow@apache.org>:
> > >>
> > >> Forgot to mention something important. When I was debugging the hash
> > >>> tests, they would pretty much always pass.
> > >>>
> > >>> But if I ran the tests normally in maven or eclipse they would always
> > >>> fail.
> > >>>
> > >>> Debugging adds a small overhead I think, that could be slowing down
> > some
> > >>> part of the code with a concurrency issue?
> > >>>
> > >>> That's an explanation. If I start a Virtualbox instance that prepares
> > >> some
> > >> load I can see the tests pass under Java 9 ... I had the Virtualbox
> > >> running
> > >> yesterday when the tests passed.
> > >>
> > >>
> > >> Just in case it helps...
> > >>>
> > >>> Interesting this surefire configuration Andreas. Do you have more
> > >>> information about it? Is it something we may have to worry about in
> > >>> components that use locale and jvm 9?
> > >>>
> > >>> I ran into an issue with the language selection dialog of izpack and
> > >> found
> > >> that this configuration solved the problem there.
> > >> It's noted in the release notes of Java 9:
> > >> http://www.oracle.com/technetwork/java/javase/9-relnote-
> > >> issues-3704069.html#JDK-8008577
> > >>
> > >> Cheers,
> > >> Andreas
> > >>
> > >>
> > >> Cheers
> > >>> Bruno
> > >>>
> > >>> Sent from Yahoo Mail on Android
> > >>> <https://overview.mail.yahoo.com/mobile/?.src=Android>
> > >>>
> > >>> On Thu, 28 Sep 2017 at 4:45, Andreas Kuhtz
> > >>> <andreas.kuhtz@gmail.com> wrote:
> > >>> Hi,
> > >>>
> > >>> I'm running Win7 and with "mvn clean verify". Checkout master.
> > >>>
> > >>> I got the hash code errors, too. But sometimes the tests pass, the
> next
> > >>> time they failed with 44 failures (the hash code verification).
> > >>>
> > >>> As I'm not sure if my antivirus kicks in and keep some files in the
> > >>> target
> > >>> dir, I ran "mvn clean" and after that "mvn clean verify".
> > >>> But now I have the 44 failures with jdk-1.7.0_67, jdk-1.8.0_131 and
> > 9+181
> > >>>
> > >>> Gary:
> > >>> To get around the issue with ServiceConfiguration
> sun.util.locale...  I
> > >>> added the following profile to the pom.xml. After that I only got the
> > 44
> > >>> errors (hash code) as with Java 7 and 8.
> > >>>
> > >>>      <profile>
> > >>>        <id>jdk9-build</id>
> > >>>        <activation>
> > >>>          <jdk>9</jdk>
> > >>>        </activation>
> > >>>        <build>
> > >>>          <plugins>
> > >>>            <plugin>
> > >>>              <artifactId>maven-surefire-plugin</artifactId>
> > >>>              <configuration>
> > >>>                <argLine>-Djava.locale.providers=COMPAT</argLine>
> > >>>              </configuration>
> > >>>            </plugin>
> > >>>          </plugins>
> > >>>        </build>
> > >>>      </profile>
> > >>>
> > >>> I'm not sure if I can help more, but if you need more info just let
> me
> > >>> know.
> > >>>
> > >>> Andreas
> > >>>
> > >>> 2017-09-27 19:10 GMT+02:00 Gary Gregory <garydgregory@gmail.com>:
> > >>>
> > >>> Using git master and 'mvn clean verify', on Windows 10, with Java 7,
> I
> > >>>>
> > >>> get
> > >>>
> > >>>> 44 failures, and I think this is all/mostly hash code problems.
> > >>>>
> > >>>> With Java 8, all tests pass.
> > >>>>
> > >>>> With Java 9, I get ONE failure: ListIteratorWrapperTest.
> > testRemove:116
> > >>>> ╗
> > >>>> ServiceConfiguration sun.util.locale....
> > >>>>
> > >>>> If I checkout the 4.1 tag and use Java 7, I get 44 failures. ARG!
> What
> > >>>>
> > >>> the
> > >>>
> > >>>> heck?
> > >>>>
> > >>>> Gary
> > >>>>
> > >>>>
> > >>>>
> > >>>> On Mon, Sep 25, 2017 at 12:02 PM, Benedikt Ritter <
> britter@apache.org
> > >
> > >>>> wrote:
> > >>>>
> > >>>> Hi,
> > >>>>>
> > >>>>> who can help with the test failures on Windows? I’d like
to push
> out
> > >>>>>
> > >>>> the
> > >>>
> > >>>> next release soon to get Collections Java 9 ready. I don’t have
> access
> > >>>>>
> > >>>> to a
> > >>>>
> > >>>>> Windows installation and I don’t feel like debugging inside
a VM
> :o)
> > >>>>>
> > >>>>> Regards,
> > >>>>> Benedikt
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>>> ------------------------------------------------------------
> > ---------
> > >>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > >>>>> For additional commands, e-mail: dev-help@commons.apache.org
> > >>>>>
> > >>>>>
> > >>>>>
> > >>>
> > >
> >
> >
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message