commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject Re: [compress] HasCharset is a bad name
Date Wed, 12 Jul 2017 13:32:44 GMT
Hello,

> Am 11.07.2017 um 06:55 schrieb Simon Spero <sesuncedu@gmail.com>:
> 
> Since it's an interface, I could change it to IHasACharset?
> 
> Or If you prefer I  could rename it to YouGiveLove?  (Lucky Millenials- you
> aren't headsonged)

I recommend to leave this kind of irony out of mailing list communication. This is probably
your personal style of communicating, but it is hard to understand in remote communication
with people from other cultural backgrounds. It makes communication more boring to remove
this kind of sugar, but it helps to avoid misunderstandings.

Cheers,
Benedikt

> 
> The name follows a pattern for interfaces of this sort, which are basically
> retrofit markers for the presence of property, (with associated getters).
> I've seen it used in other projects, but it might be bleed through from
> some  OWL / RDF patterns.
> 
> I'm not in love with the pattern but it required the least thought :)
> 
> (java 8 makes this sort of interface moot, as the accessor can be added as
> a default method. It is even be a candidate for the proper use of Optional.
> )
> 
> On Jul 5, 2017 1:14 PM, "Gary Gregory" <garydgregory@gmail.com> wrote:
> 
> Hi All,
> 
> The new interface name HasCharset is pretty bad IMO.
> 
> CharsetProvider is the obvious (to me) better name even though there
> already is a class called java.nio.charset.spi.CharsetProvider.
> 
> Alternatives could be CharsetContainer, CharsetAccessor, CharsetGetter, ?
> 
> Gary


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message