commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Amey Jadiye <ameyjad...@gmail.com>
Subject Re: [compress] HasCharset is a bad name
Date Tue, 11 Jul 2017 04:40:43 GMT
HasCharset is certainly bad and also CharsetAccessor sounds like class name
not as Interface , I think Charsetable CharsetAccesable or CharsetAware Is
better as Interface name.

Regards,
Amey

On Tue, Jul 11, 2017, 3:33 AM Gary Gregory <garydgregory@gmail.com> wrote:

> I renamed HasCharset to CharsetAccessor (until someone comes up with a
> better name before 1.15.)
>
> Gary
>
> On Wed, Jul 5, 2017 at 11:57 PM, Stefan Bodewig <bodewig@apache.org>
> wrote:
>
> > On 2017-07-05, Gary Gregory wrote:
> >
> > > The new interface name HasCharset is pretty bad IMO.
> >
> > fair enough.
> >
> > > CharsetProvider is the obvious (to me) better name even though there
> > > already is a class called java.nio.charset.spi.CharsetProvider.
> >
> > I don't think so, this really is a marker interface for classes also
> > implementing ZipEncoding (Simon didn't want to extend the existing
> > interface).
> >
> > Hmm, maybe we could make it extend ZipEncoding and call it something
> > like ZipEncodingWithCharset?
> >
> > Stefan
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> > For additional commands, e-mail: dev-help@commons.apache.org
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message