commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brosius <dbros...@mebigfatguy.com>
Subject Modern dependencies among commons
Date Wed, 26 Jul 2017 12:23:04 GMT
Hi Folks,


     I'd like to see all of our common components uptake the 'latest' 
versions of other commons components, to encourage their adoption. For 
instance, commons-beanutils still uses commons-collections 3, and so 
when i want to use commons-collections4 myself, i now have to have both 
in the classpath. While there are no conflicts, it's just messy. People 
auto-import the wrong version of collections classes into our code base, 
for instance. If we could get updates to at least the right (major) 
version of jars that would be great.


--dave


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message