commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject Re: [VOTE] Release CRYPTO 1.0.0 based on RC1
Date Fri, 29 Jul 2016 22:41:44 GMT
We only have two binding votes. PMCs please review this RC and vote! :-)

Jörg Schaible <joerg.schaible@gmx.de> schrieb am Fr., 29. Juli 2016 um
21:14:

> Sun, Dapeng wrote:
>
> > Thank Jörg for the testing.
> >
> >>>I am building crypto with my compiler zoo on Gentoo Linux with OpenSSL
> >>>1.02h installed.
> > I don't have environment with Gentoo Linux, I just tested the library
> with
> > OpenJDK on pure Ubuntu OS: OpenJDK 7 on Ubuntu 14.04 and OpenJDK 8 on
> > Ubuntu 16.04, All of them are passed:
>
> As Xianda found out, my /tmp is missing the exec permission. So the
> behavior
> was quite normal.
>
> [snip]
>
> >>> However, the build first fails and then hangs in a unit test when
> >>> building with IBM JDK 7
> >
> > About building CRYPTO on IBM JDK, I wonder if we should support it,
> > because even for different minor versions of IBM JDK 7, the JNI header
> > files may be changed, the change would be cause some weird failures at
> > native. But the binary would be right, I have test the RC1 on latest IBM
> > JDK 7 from their official website, all the tests are okay.
> >
> > About the build fails, I did't encounter it before, if it is the same
> > environment with openjdk, I think we can fix the Openssl shade issue
> > first, if we encounter it again, we can run the pure unit tests, I
> > uploaded them to my personal repo:
> > https://github.com/sundapeng/TCRYPTO.git, could you help verify it in
> your
> > environment?( The cached files in maven should be cleaned before test,
> for
> > example: rm ~/.m2/repository/org/apache/commons/commons-crypto/ -rf).
> >
> > About the test hang, if the hanging UT is the test for JavaSecureRandom,
> > it should be an issue about SecureRandom in JDK.
> > https://bugs.openjdk.java.net/browse/JDK-6577564
> >
> >
> > Here is the IBM JDK in my environment:
> > java version "1.7.0"
> > Java(TM) SE Runtime Environment (build pxa6470_27sr3fp40-20160422_01(SR3
> > FP40)) IBM J9 VM (build 2.7, JRE 1.7.0 Linux amd64-64 Compressed
> > References 20160406_298393 (JIT enabled, AOT enabled) J9VM -
> > R27_Java727_SR3_20160406_0942_B298393
> > JIT  - tr.r13.java_20160328_114186
> > GC   - R27_Java727_SR3_20160406_0942_B298393_CMPRSS
> > J9CL - 20160406_298393)
> > JCL - 20160421_01 based on Oracle jdk7u101-b14
>
> Well, it seems my version is rather old now, I should update it anyway. If
> it works at least for you, it's also fine for me, since normally nobody
> tests on IBM JDK ;-)
>
> Therefore: +1, release it
>
> Cheers,
> Jörg
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message