commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrey Loskutov <losku...@gmx.de>
Subject Re: [BCEL] 5.3 is going to be messy
Date Tue, 07 Jun 2016 15:55:21 GMT
On Tuesday 07 June 2016 15:37 Benedikt Ritter wrote:
> > > I propose we create the 5.x branch now. Those who want/need a compatible
> > > release can work that out in that branch. All others can work on trunk to
> > > get BCEL 6 out of the door with Java 7 and Java 8 compatibility.
> >
> > Sorry, IMHO the *only* reason to release 5.3 after many years *IS* the
> > Java 7/8 compatibility.
> > We (user) just want something stable we can use on a modern JVM (and Java
> > 7 is already *obsoleted*!), nothing more.
> > Before thinking about new API's, please just release something running on
> > Java 7/8.
> >
> 
> So that's a word from our users.
> 
> What now? Revert the Package rename in trunk back to org.apache.bcel and
> finish that 5.3 release? I have no idea what's broken wrt to compatibility
> because you  cant compare with the ne coords anymore.

Yes. Please undo "package rename" aka BCEL-222 thing first. 
This is an easy task (requires ~5 minutes in the IDE), see commit https://github.com/iloveeclipse/commons-bcel/commit/ae98757798ab54992a6e7a1cf6429a2a44e0e67c
. After that we will see how bad/good the state is. 
I don't think the state is really bad, otherwise I wouldn't be able to create experimental
port of FB in few hours.
See https://github.com/findbugsproject/findbugs/issues/106 - the commits referenced there
describe what I saw on breakage from the FindBugs side. 
Of course that is only from the FindBugs point of view.

-- 
Kind regards,
google.com/+AndreyLoskutov

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message