commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jochen Wiedmann <jochen.wiedm...@gmail.com>
Subject Re: [io] Make requirement Java 7?
Date Tue, 26 Apr 2016 13:30:42 GMT
On Tue, Apr 26, 2016 at 3:28 PM, Emmanuel Bourg <ebourg@apache.org> wrote:
> Le 26/04/2016 14:57, Dave Brosius a écrit :
>
>> The extra management that's required is not worth the
>> 2 people who want a new version of commons-io for java 6. We are talking
>> about an end of life date coming up on 4 years.
>
> There is no extra management besides configuring the Maven compiler
> plugin to generate Java 6 bytecode and refraining from using Java 7 APIs
> unless absolutely required (and preferably in dedicated classes).
>
> commons-io is our most used component, we have to be conservative as it
> impacts many projects.

Besides, what is the problem with creating a 2.x branch new and
changing trunk to version 3? If there is further development in the
2.x (aka Java 6) branch: Very well. If not, what is the problem?

Jochen



-- 
The next time you hear: "Don't reinvent the wheel!"

http://www.keystonedevelopment.co.uk/wp-content/uploads/2014/10/evolution-of-the-wheel-300x85.jpg

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message