commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <>
Subject Re: [math] Name of the new TLP
Date Sun, 24 Jan 2016 22:41:39 GMT

> On Jan 24, 2016, at 3:17 PM, Gilles <> wrote:
> Just plain and simple "Apache Math" maybe?
> Or is it taken already?

It's not taken; but I thought it was too broad-sounding and in fact umbrella-ish.  There are
other ASF projects that do math-relates things.  I think adding "components" makes it look
more like a library of base components that other math-related projects can use.

> Gilles
>> On Sun, 24 Jan 2016 14:46:17 -0700, Phil Steitz wrote:
>>> On 1/24/16 2:16 PM, James Carman wrote:
>>> I guess it depends on the scope of what the new TLP is going to do.
>> This is slightly jumping the gun, as we do have the opportunity in
>> forming the new TLP to revisit the initial goals of [math]; but I
>> suspect that initially at least we will mostly continue to be a
>> general-purpose Java math library, trying to provide IP-clean,
>> easily integrated, standard algorithm-based solutions to common math
>> programming problems.  We have grown to the point where we will
>> almost certainly break the distribution up into separate
>> "components."  No umbrella, but likely multiple release artifacts.
>> Similar in some ways to what happened with [http], which is why I
>> suggested the same approach to naming.
>> Regarding picking a mathematician for the name, I don't much like
>> that idea as whoever you choose, you end up loading some math area
>> and / or cultural bias into the name.
>> Phil
>>> Umbrella projects aren't that popular these days, from what I understand.
>>> Maybe an homage to a famous mathematician? Apache Newton? Apache Euler?
>>> Apache Euclid?
>>>> On Sun, Jan 24, 2016 at 4:08 PM Phil Steitz <>
>>>> We need to agree on a name.  My own preference is for a boring,
>>>> descriptive name, but I am manifestly not a marketing guy, so won't
>>>> be offended if others want to be more creative.
>>>> My suggestion is
>>>> MathComponents
>>>> Hearkens back to HttpComponents, which has worked pretty well.
>>>> Phil
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message