commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Uwe Barthel <bart...@x-reizend.de>
Subject Re: [JXPATH] Java Version
Date Wed, 02 Dec 2015 20:17:14 GMT
Hi,

should we start a official vote for the Java version topic for JXPath or following the release
plan provided by Benedikt?

-- Uwe


> On 25 Nov 2015, at 20:18, Gary Gregory <garydgregory@gmail.com> wrote:
> 
> On Wed, Nov 25, 2015 at 9:27 AM, sebb <sebbaz@gmail.com> wrote:
> 
>> On 25 November 2015 at 16:49, Gary Gregory <garydgregory@gmail.com> wrote:
>>> On Tue, Nov 24, 2015 at 11:57 PM, Uwe Barthel <barthel@x-reizend.de>
>> wrote:
>>> 
>>>> 
>>>>> Do you like to start these changes before or after the release 1.4?
>>>>>>> I prefer to create the release as soon as possible and start
rework
>> on
>>>>>> that baseline.
>>>>>> 
>>>>> 
>>>> Maybe my statement was a bit ambiguous. I'm fine with a Java version 1.6
>>>> or 1.7 but would not wait until the code is overall refurbished.
>>> 
>>> 
>>> RERO! :-)
>> 
>> Repent at leisure.
>> 
>>> 
>>>> 
>>>> 
>>>> The problem with JDK 1.4 is, that I don't have it on any machine. The
>>>>> oldest JDK you can get for Mac OS X to my knowledge is 1.6.
>>>>> 
>>>> 
>>>> Unfortunately, same here.
>>> 
>>> 
>>> No longer supporting 1.4 is not a showstopper IMO. Bumping the JRE to 1.6
>>> or 1.7 and releasing would be OK with me.
>> 
>> Same here.
>> 
>> However, since the code was written for 1.4, it won't have generics
>> support.
>> 
>> Do we want to release code which requires 1.5+ but which does not
>> compile cleanly on 1.5+?
>> 
>> It's quite a lot of work adding generics, and mistakes can be hard to
>> correct without potentially causing compatibility issues.
>> 
>> I don't think there is an easy solution here. However, unless the time
>> can be put in to add generics properly, I think it would be better not
>> to do so at all.
>> In which case, change the Java version to the minimum that is easy to
>> build/test, i.e. 1.6.
>> This would be with the intention of doing another release before too
>> long that fixes up generics etc.
>> That could target 1.7.
>> 
> 
> +1
> 
> Gary
> 
> 
>> 
>>> Gary
>>> 
>>>> 
>>>> 
>>>> -- Uwe
>>>> 
>>>> 
>>>> 
>>>> 
>>>> ---------------------------------------------------------------------
>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>> 
>>>> 
>>> 
>>> 
>>> --
>>> E-Mail: garydgregory@gmail.com | ggregory@apache.org
>>> Java Persistence with Hibernate, Second Edition
>>> <http://www.manning.com/bauer3/>
>>> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
>>> Spring Batch in Action <http://www.manning.com/templier/>
>>> Blog: http://garygregory.wordpress.com
>>> Home: http://garygregory.com/
>>> Tweet! http://twitter.com/GaryGregory
>> 
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>> 
>> 
> 
> 
> -- 
> E-Mail: garydgregory@gmail.com | ggregory@apache.org
> Java Persistence with Hibernate, Second Edition
> <http://www.manning.com/bauer3/>
> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> Spring Batch in Action <http://www.manning.com/templier/>
> Blog: http://garygregory.wordpress.com
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message