commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [BCEL] Java version
Date Thu, 13 Aug 2015 18:47:53 GMT
On 13 August 2015 at 17:58, Gary Gregory <garydgregory@gmail.com> wrote:
> The POM sets the source version to Java 1.5 but the code does not compile
> on Java 1.5.
>
> I say we just move the req to java 7 or 8 and move on.

I would be OK with Java 7 as a minimum.

I realise that I normally argue for the minimum Java version, but BCEL
is different from most of the other Commons components.

It is likely to be mainly used in Maven or stand-alone applications,
and it seems likely that any usage will be on a host that can readily
be upgraded to at least Java 7.

This is not the case for many of the other Commons components which
are likely to be deeply embedded in large complex systems where Java
upgrades are much harder to test and implement.

> Gary
>
> --
> E-Mail: garydgregory@gmail.com | ggregory@apache.org
> Java Persistence with Hibernate, Second Edition
> <http://www.manning.com/bauer3/>
> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> Spring Batch in Action <http://www.manning.com/templier/>
> Blog: http://garygregory.wordpress.com
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message