commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Brosius <dbros...@mebigfatguy.com>
Subject Re: [bcel] PLSE changes to BCEL
Date Mon, 23 Feb 2015 13:11:02 GMT
6.0 already has breaking changes, thus the move to version 6.0.

One specific case is that annotations are now coming in as annotations 
as opposed to unknown code attributes. Code that relies on parsing 
annotations thru unknown code attributes will break.



On 02/23/2015 07:30 AM, Ben McCann wrote:
> Ok, thanks. The part I wasn't sure about is if that was the only breaking
> change. It sounds like you're saying the other changes aren't breaking.
>
> -Ben
> On Feb 22, 2015 11:14 PM, "Emmanuel Bourg" <ebourg@apache.org> wrote:
>
>> Le 23/02/2015 05:39, Ben McCann a écrit :
>>
>>> Are many of your changes breaking backward compatibility? I'm wondering
>> if
>>> there are only a few that do if we could prioritize them in order to get
>> a
>>> 6.0 release out with the rest of the changes coming in a 6.1.
>> Hi Ben,
>>
>> I think we already answered this question, BCEL-209 is a breaking change
>> because it affects the public API. Your help resolving this issue would
>> be welcome. We have to understand why the current design was chosen and
>> if the design proposed by Mark may cause any issue later.
>>
>> Emmanuel Bourg
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message