commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [ALL] Time for CP 37?
Date Sat, 24 Jan 2015 15:50:09 GMT
I think I've solved the issue with the icu class.

I had mistakenly added animal-sniffer to the test phase, however it
defaults to process-classes.

This phase occurs before the test phase when it appears that cobertura
updates the classpath.

So now animal-sniffer does not see ICU (read that aloud!)

As to the problem with build-helper requiring the validate phase: I
don't think that's actually a problem, or at least not one that can be
solved.

When Maven is called with a single goal, that's all it executes -
there's no way to force other goals to be executed.

It's not actually possible to invoke animal-sniffer:check directly
from the command-line.
[It only works with CP37 because of the additional profile which
defines the required parameters]
Nor does it make sense to do so, because the plugin must be run after
the compile phase.


I've deployed the updated SNAPSHOT - does Lang build for you now?


On 24 January 2015 at 14:36, sebb <sebbaz@gmail.com> wrote:
> Looks like the cobertura plugin is one source of the bad icu dependency
>
> This works:
> mvn site -Psite-basic
>
> This causes animal sniffer to fail
> mvn site -Psite-basic -Dcobertura.skip=false
>
>
> On 24 January 2015 at 13:13, sebb <sebbaz@gmail.com> wrote:
>> I get the problem as well with mvn site.
>>
>> It looks like additional jars are added to the classpath when the site
>> phase is specified.
>> I don't think animal sniffer should be considering them, but that may
>> be a Maven plugin restriction rather than a bug in animal sniffer.
>>
>> I am a bit wary of unconditionally adding the dependency to CP 37 (if
>> we do, the version should be defined as a property).
>>
>> Maybe it could be added just to the animal sniffer setup.
>> I'll do some experiments now I can reproduce the issue.
>>
>> ==
>>
>> There is another (minor) issue in CP37.
>> This fails:
>>
>> mvn animal-sniffer:check
>>
>> That's because the plugin needs the validate phase to have been run in
>> order to define the properties it needs.
>>
>> I put the build-helper (it defines the properties) into a separate
>> profile as I thought they might be useful elsewhere.
>>
>> I need to look at that again too.
>>
>> As a work-round, one can do
>>
>> mvn validate animal-sniffer:check
>>
>> but that is not ideal.
>>
>>
>>
>> On 24 January 2015 at 12:11, Benedikt Ritter <britter@apache.org> wrote:
>>> 2015-01-24 13:05 GMT+01:00 Benedikt Ritter <britter@apache.org>:
>>>
>>>>
>>>>
>>>> 2015-01-23 16:39 GMT+01:00 sebb <sebbaz@gmail.com>:
>>>>
>>>>> On 23 January 2015 at 14:52, Benedikt Ritter <britter@apache.org>
wrote:
>>>>> > 2015-01-23 15:10 GMT+01:00 sebb <sebbaz@gmail.com>:
>>>>> >
>>>>> >> On 23 January 2015 at 13:48, Benedikt Ritter <britter@apache.org>
>>>>> wrote:
>>>>> >> > 2015-01-23 14:20 GMT+01:00 sebb <sebbaz@gmail.com>:
>>>>> >> >
>>>>> >> >> I think it's probably time to release Commons Parent
37.
>>>>> >> >>
>>>>> >> >> Any more quick fixes to be added, or is it OK to go?
>>>>> >> >>
>>>>> >> >
>>>>> >> > I'd like to find out what is going on with the animal-sniffer
plugin
>>>>> when
>>>>> >> > building [lang]. I'll have a look at this tomorrow, okay?
>>>>> >>
>>>>> >> I don't get a problem.
>>>>> >> What Java version are you using, and which Maven?
>>>>> >>
>>>>> >
>>>>> > $ mvn -v
>>>>> > Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1;
>>>>> > 2014-12-14T18:29:23+01:00)
>>>>> > Maven home: /usr/local/Cellar/maven/3.2.5/libexec
>>>>> > Java version: 1.7.0_71, vendor: Oracle Corporation
>>>>> > Java home:
>>>>> > /Library/Java/JavaVirtualMachines/jdk1.7.0_71.jdk/Contents/Home/jre
>>>>> > Default locale: de_DE, platform encoding: UTF-8
>>>>> > OS name: "mac os x", version: "10.10.1", arch: "x86_64", family:
"mac"
>>>>> >
>>>>>
>>>>> Works fine for me:
>>>>>
>>>>> Apache Maven 3.2.5 (12a6b3acb947671f09b81f49094c53f426d8cea1;
>>>>> 2014-12-14T17:29:23+00:00)
>>>>> Maven home: /opt/apache-maven-3.2.5
>>>>> Java version: 1.7.0_75, vendor: Oracle Corporation
>>>>> Java home:
>>>>> /Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/jre
>>>>> Default locale: en_US, platform encoding: UTF-8
>>>>> OS name: "mac os x", version: "10.9.5", arch: "x86_64", family: "mac"
>>>>>
>>>>> Also worked using Java 1.7.0_65
>>>>>
>>>>> I tested using:
>>>>>
>>>>> mvn clean test -DskipTests
>>>>>
>>>>
>>>> mvn clean test works fine for me as well. It's the site build which fails.
>>>> I've removed the bad jar, but the error persists. Any idea?
>>>>
>>>
>>> Adding the workaround from
>>> http://stackoverflow.com/questions/6751920/tomcat-7-servlet-3-0-invalid-byte-tag-in-constant-pool
>>> to the pom.xml:
>>>
>>> <dependencyManagement>
>>>   <dependencies>
>>>     <dependency>
>>>       <groupId>com.ibm.icu</groupId>
>>>       <artifactId>icu4j</artifactId>
>>>       <version>3.4.4</version>
>>>     </dependency>
>>>   </dependencies>
>>> </dependencyManagement>
>>>
>>> Solves the problem for me...
>>>
>>>
>>>>
>>>>
>>>>>
>>>>> >>
>>>>> >> > Benedikt
>>>>> >> >
>>>>> >> >
>>>>> >> >>
>>>>> >> >> S.
>>>>> >> >>
>>>>> >> >>
>>>>> ---------------------------------------------------------------------
>>>>> >> >> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> >> >> For additional commands, e-mail: dev-help@commons.apache.org
>>>>> >> >>
>>>>> >> >>
>>>>> >> >
>>>>> >> >
>>>>> >> > --
>>>>> >> > http://people.apache.org/~britter/
>>>>> >> > http://www.systemoutprintln.de/
>>>>> >> > http://twitter.com/BenediktRitter
>>>>> >> > http://github.com/britter
>>>>> >>
>>>>> >> ---------------------------------------------------------------------
>>>>> >> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> >> For additional commands, e-mail: dev-help@commons.apache.org
>>>>> >>
>>>>> >>
>>>>> >
>>>>> >
>>>>> > --
>>>>> > http://people.apache.org/~britter/
>>>>> > http://www.systemoutprintln.de/
>>>>> > http://twitter.com/BenediktRitter
>>>>> > http://github.com/britter
>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>>>
>>>>>
>>>>
>>>>
>>>> --
>>>> http://people.apache.org/~britter/
>>>> http://www.systemoutprintln.de/
>>>> http://twitter.com/BenediktRitter
>>>> http://github.com/britter
>>>>
>>>
>>>
>>>
>>> --
>>> http://people.apache.org/~britter/
>>> http://www.systemoutprintln.de/
>>> http://twitter.com/BenediktRitter
>>> http://github.com/britter

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message