commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [VOTE] (lazy consensus) Release Commons Parent 37
Date Tue, 27 Jan 2015 13:50:41 GMT
The problem is that Java8 class files include some new constant types
that the currently available release of BCEL cannot handle.

A work-round is to use Java 7 to run Maven when building the site.

On 27 January 2015 at 13:31, sebb <sebbaz@gmail.com> wrote:
> It's not CP37 because Java8 also fails with CP36
>
> Nor is it Cobertura, because it fails with -Psite-basic -Dclirr.skip=false
>
> Unfortunately -X does not seem to show the name of the offending class.
>
> I'm continuing to investigate, but I think we can let the CP37 release go ahead.
>
> It may be that we will need a CP38 to fix the Java8 issue, but that's
> for another day.
>
>
> On 27 January 2015 at 13:23, Benedikt Ritter <britter@apache.org> wrote:
>> 2015-01-27 13:42 GMT+01:00 sebb <sebbaz@gmail.com>:
>>
>>> On 27 January 2015 at 08:10, Benedikt Ritter <britter@apache.org> wrote:
>>> > 2015-01-25 12:15 GMT+01:00 sebb <sebbaz@gmail.com>:
>>> >
>>> >> Hello All,
>>> >>
>>> >> The Apache Commons Parent POM provides common settings for all Apache
>>> >> Commons components.
>>> >>
>>> >>
>>> >> This is a VOTE to release Commons Parent 37 from RC2.
>>> >>
>>> >>
>>> >> This VOTE by LAZY-CONSENSUS is open for at least 72 hours until
>>> >> January 28 11:30 UTC.
>>> >>
>>> >>
>>> >> Changes in this version include:
>>> >>
>>> >> Update plugins, add Animal Sniffer and site-basic profile
>>> >>
>>> >> New features:
>>> >> o                   Added Animal Sniffer profile (active by default)
>>> >> o                   Allow to configure dependency excludes of
>>> >> bundle-plugin with commons.osgi.excludeDependencies
>>> >> o                   Added property commons.changes.onlyCurrentVersion
>>> >> for changes plugin Jira report
>>> >> o                   Allow changes Jira report maxEntries to be
>>> >> overridden (default 100)
>>> >> o                   Allow changes Jira report runOnlyAtExecutionRoot
>>> >> to be overridden
>>> >> o                   Added site-basic profile to allow quick generation
>>> >> of the basic site docs
>>> >>
>>> >> Changes:
>>> >> o                   Update minimum Maven prerequisite (as defined by
>>> >> Findbugs) 3.0 -> 3.0.1
>>> >> o                   Update org.apache:apache 15 to 16 (nop for
>>> >> Commons: maven-compiler-plugin already contained source/target)
>>> >> o                   Update Maven Project Info Reports Plugin : 2.7 =>
>>> 2.8
>>> >> o                   merged maven-3 profile into main body (Maven 2 is
>>> >> no longer supported)
>>> >> o                   renamed the profile jdk7-findbugs to
>>> >> jdk7-plugin-fix-version
>>> >> o                   Update GPG Plugin : 1.5 => 1.6
>>> >> o                   Update Antrun Plugin : 1.7 => 1.8
>>> >>
>>> >>
>>> >> The files:
>>> >>
>>> https://repository.apache.org/content/repositories/orgapachecommons-1079/
>>> >>
>>> >> /org/apache/commons/commons-parent/37/commons-parent-37.pom
>>> >> (SHA1: a85dfae7a1295e5aed75bd952e6795
>>> >> 832e4abcc5)
>>> >>
>>> >> /org/apache/commons/commons-parent/37/commons-parent-37-site.xml
>>> >> (SHA1: 4353be4df574c893f54baea75a816a80d892322a)
>>> >>
>>> >> KEYS:
>>> >> http://www.apache.org/dist/commons/KEYS
>>> >>
>>> >> The tag:
>>> >>
>>> >>
>>> >>
>>> https://svn.apache.org/repos/asf/commons/proper/commons-parent/tags/commons-parent-37-RC2/
>>> >>   Revision:  1654641
>>> >>
>>> >> The site: None.
>>> >>
>>> >
>>> > +/-0
>>> >
>>> > I've created a git fork and activated Travis CI for it [1]. It only works
>>> > for oraclejdk7. openjdk6 fails because of the FindBugs plugin, which
>>> seems
>>> > to require Java 7.
>>>
>>> Yes, it does, but there is a profile (jdk7-plugin-fix-version) to fix
>>> the Findbugs version.
>>> It should use 2.5.5 unless the profile is activated, in which case it
>>> uses 3.0.0, which does require Java7
>>>
>>> There's a bug in the lang pom.xml; it unconditionally uses 3.0.0
>>> instead of commons.findbugs.version
>>> So nothing to do with CP 37 (it would also fail with CP 36)
>>>
>>> > oraclejdk8 fails during site build with invalid byte tag
>>> > in constant pool foobar. I did not have to time yet to dig into that.
>>>
>>> Need to run Maven with -e commandline flag to debug that
>>>
>>
>> I've updated my mirror to use the commons.findbugs.version. It now works
>> for Java 6 and 7. The failing build for Java 8 is probably related to
>> cobertura. I do not consider this to be a blocker for CP 37.
>>
>> Thanks!
>> Benedikt
>>
>>
>>>
>>> > Benedikt
>>> >
>>> > [1] https://travis-ci.org/britter/commons-lang
>>> >
>>> >
>>> >>
>>> >> ---------------------------------------------------------------------
>>> >> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> >> For additional commands, e-mail: dev-help@commons.apache.org
>>> >>
>>> >>
>>> >
>>> >
>>> > --
>>> > http://people.apache.org/~britter/
>>> > http://www.systemoutprintln.de/
>>> > http://twitter.com/BenediktRitter
>>> > http://github.com/britter
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>>
>>
>> --
>> http://people.apache.org/~britter/
>> http://www.systemoutprintln.de/
>> http://twitter.com/BenediktRitter
>> http://github.com/britter

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message