commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [VOTE] Release Compress 1.10 Based on RC1
Date Fri, 30 Jan 2015 11:06:03 GMT
On 2015-01-30, sebb wrote:

> On 30 January 2015 at 08:20, Stefan Bodewig <bodewig@apache.org> wrote:
>> On 2015-01-28, Benedikt Ritter wrote:

>>> - PROPOSAL.txt is not in the src archives. Should it be?

>> This is only there for historical reasons, I don't even think the other
>> components still have a file like this.  I've removed it completely.

>>> - there is a typo in the release notes. The first line says "Apache
>>> Apache Commons Compress"

>> fixed, thanks.

>>> - will clients who extended ZCompressorInputStream be affected by the
>>> change in it's superclass hierarchy? In other words, is the change to
>>> ZCompressorInputStream reported by clirr binary compatible with 1.9?

>>> The last one would be a blocker for me. It could be resolved by restoring
>>> the _internal_ package and deprecate it right away.

>> It is reported as not compatible, so yes, we are breaking backwards
>> compatibility.

> Note that Clirr does not distinguish binary and source compatibility.
> Breaking binary compatibility is almost never a good idea.
> However source compatibility may be less important in some cases.

> Which incompatibility is it?

The superclass of ZCompressorInputStream has changed from one we've
removed with the old __internal__ package to a new one in the now
supported lzw package.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message