commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles <gil...@harfang.homelinux.org>
Subject Re: [Math] Clirr error for "SmoothingPolynomialBicubicSplineInterpolator"
Date Fri, 28 Nov 2014 13:48:37 GMT
On Thu, 27 Nov 2014 21:44:58 +0100, Gilles wrote:
> Hello.
>
> The class
> 
> "o.a.c.m.analysis.interpolation.SmoothingPolynomialBicubicSplineInterpolator"
> breaks binary compatibility due to the replacement of
> "BicubicSplineInterpolator" by
> "PiecewiseBicubicSplineInterpolator".
> It must be fixed before releasing 3.4.

I propose to simply deprecate the class in 3.4, and drop it in 4.0.
[Anyways, I think that it's unusable in practice.]
Any objection?


Regards,
Gilles


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message