commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Eckenfels <e...@zusammenkunft.net>
Subject Re: How to run unit test ProviderRenameTests?
Date Tue, 06 May 2014 20:05:58 GMT
Hello,

I tried several times to understand how the testconfiguration and suite
building is working but I failed.

I noticed that most of the tests have
totally unrelated class-names when run in Eclipse JUnit runner (but can
be used). So I typically do the same as you did, make standalone tests
or run the whole suite. 

You have my sympathies for trying :) 

Gruss
Bernd


 Am Tue, 6 May 2014 06:53:03 -0700
(PDT) schrieb Woonsan Ko <woon_san@yahoo.com>:

> Hi,
> 
> I'm trying to reproduce VFS-298 with the unit test (in trunk)
>  because I met a similar exception in my application, but I can't 
> execute the unit test, ProviderRenameTests.
> When I run `mvn clean install' in the root folder, I can't find
> 'core/target/surefire-reports/*ProviderRenameTests*.txt'.
> 
> Also, `mvn -P ftp test -Dtest=ProviderRenameTests' in the core/
> directory gives NPEs like the following:
> 
> java.lang.NullPointerException: null
>     at
> org.apache.commons.vfs2.test.AbstractProviderTestCase.runTest(AbstractProviderTestCase.java:200)
> at junit.framework.TestCase.runBare(TestCase.java:141) ...
> 
> Any hints?
> 
> Regards,
> 
> Woonsan
> 
> P.S, I'm sending this again because my message hasn't seem to be sent
> yesterday. Apologies if posted twice.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message