commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Woonsan Ko <woon_...@yahoo.com>
Subject Re: How to run unit test ProviderRenameTests?
Date Wed, 07 May 2014 22:39:04 GMT
I figured out how to run the unit test:

$ mvn -Pftp clean test -Dtest=FtpProviderTestCase

FtpProviderTestCase extends ProviderTestSuite which seems to add tests programmatically (#addBaseTests()).
So, when I run the above command, it executes 76 tests including ProviderRenameTests. It was
also possible to debug in Eclipse from FtpProviderTestCase.

Thanks anyway,

Woonsan

P.S. Strangely my messages to dev@ are not posted (not found in archive either) or delayed
too much (>1day) nowadays. So, sorry if this is posted twice.


On Tuesday, May 6, 2014 5:29 PM, Bernd Eckenfels <ecki@zusammenkunft.net> wrote:
 
Hello,
>
>I tried several times to understand how the testconfiguration and suite
>building is working but I failed.
>
>I noticed that most of the tests have
>totally unrelated class-names when run in Eclipse JUnit runner (but can
>be used). So I typically do the same as you did, make standalone tests
>or run the whole suite. 
>
>You have my sympathies for trying :) 
>
>Gruss
>Bernd
>
>
>Am Tue, 6 May 2014 06:53:03 -0700
>(PDT) schrieb Woonsan Ko <woon_san@yahoo.com>:
>
>
>> Hi,
>> 
>> I'm trying to reproduce VFS-298 with the unit test (in trunk)
>>  because I met a similar exception in my application, but I can't 
>> execute the unit test, ProviderRenameTests.
>> When I run `mvn clean install' in the root folder, I can't find
>> 'core/target/surefire-reports/*ProviderRenameTests*.txt'.
>> 
>> Also, `mvn -P ftp test -Dtest=ProviderRenameTests' in the core/
>> directory gives NPEs like the following:
>> 
>> java.lang.NullPointerException: null
>>     at
>> org.apache.commons.vfs2.test.AbstractProviderTestCase.runTest(AbstractProviderTestCase.java:200)
>> at junit.framework.TestCase.runBare(TestCase.java:141) ...
>> 
>> Any hints?
>> 
>> Regards,
>> 
>> Woonsan
>> 
>> P.S, I'm sending this again because my message hasn't seem to be sent
>> yesterday. Apologies if posted twice.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>For additional commands, e-mail: dev-help@commons.apache.org
>
>
>
>
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message