commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [all] Dependency resolution.
Date Tue, 22 Apr 2014 21:48:49 GMT
Petar Tahchiev wrote:

> Hi guys,
> 
> my exception occurs if I have only commons-lang2 in my classpath. I wasn't
> aware you can have both in the classpath, but now that I put them both in
> the classpath it all works. It's not very nice solution, but I'll stick
> them both in. I still think we should issue a new release for the
> mentioned projects if they have enough issues solved. This way we can
> update the dependencies and refactor to the correct groupId.

This is not possible without breaking binary compatibility of the commons-
configuration package - unfortunately. The problem is the 
ConfigurationException which is derived from an Exception of the old 
commons-lang and therefore part of the Configuration API which requires old 
commons-lang to be part of the compiler classpath ... :-/

For configuration2 we should have ConfigurationException derived directly 
from an Exception of the Java runtime.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message