commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petar Tahchiev <paranoia...@gmail.com>
Subject [all] Dependency resolution.
Date Tue, 22 Apr 2014 14:07:52 GMT
Hi guys,

I found out I'm using quite a lot of the commons-*:commons-* artifacts in
my project so I decided to upgrade them to their new version in
org.apache.commons:whatever. I only upgraded those that I could so now I
have for instance org.apache.commons:commons-lang3 in my classpath, but
unfortunately I also have commons-confguration:commons-configuration:1.9
and there I get exceptions like these:

Caused by: java.lang.NoClassDefFoundError:
org/apache/commons/configuration/ConfigurationException
        at java.lang.Class.getDeclaredMethods0(Native Method)
        at java.lang.Class.privateGetDeclaredMethods(Class.java:2521)
        at java.lang.Class.getDeclaredMethods(Class.java:1845)
        at
org.springframework.orm.jpa.support.PersistenceAnnotationBeanPostProcessor.findPersistenceMetadata(PersistenceAnnotationBeanPostProcessor.java:402)
        at
org.springframework.orm.jpa.support.PersistenceAnnotationBeanPostProcessor.postProcessMergedBeanDefinition(PersistenceAnnotationBeanPostProcessor.java:332)
        at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.applyMergedBeanDefinitionPostProcessors(AbstractAutowireCapableBeanFactory.java:908)
        at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:512)
        at
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:475)
        at
org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:304)
        at
org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:228)


So because commons-configuration:commons-configuration requires
commons-lang2 as a dependency I'm forced to downgrade to commons-lang2.

My request is this: is it possible to upgrade ALL the commons artifacts to
the correct repository groupId (org.apache.commons) and upgrade their
dependencies? Most of them are already there, and those which are not will
most certainly benefit from a new release (i guess there's been quite a
while they haven't been released and there might be some resolved issues in
the JIRA).

Is there anyone against having a new release on: commons-logging,
commons-fileupload, commons-codec,
commons-configuration,commons-beanutils,commons-digester and the rest of
the projects which are still using the incorrect groupId.

-- 
Regards, Petar!
Karlovo, Bulgaria.
---
Public PGP Key at:
https://keyserver1.pgp.com/vkd/DownloadKey.event?keyid=0x19658550C3110611
Key Fingerprint: A369 A7EE 61BC 93A3 CDFF  55A5 1965 8550 C311 0611

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message