commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [VOTE] Release Commons Exec 1.2-RC2
Date Sat, 04 Jan 2014 10:16:22 GMT
Gary Gregory wrote:

> On Fri, Jan 3, 2014 at 11:08 AM, sebb <sebbaz@gmail.com> wrote:
> 
>> On 3 January 2014 15:04, Gary Gregory <garydgregory@gmail.com> wrote:
>> > On Fri, Jan 3, 2014 at 6:36 AM, Jörg Schaible <joerg.schaible@gmx.de>
>> wrote:
>> >
>> >> Hi Gary,
>> >>
>> >> I tried to build from source with my compiler zoo. I cannot test Java
>> 1.3
>> >> compatibility, because the lack of such an environment on my side.
>> >>
>> >> Java 1.4:
>> >>
>> >> It is not possible to build with Maven 2.0.x, since the
>> >> assembly-plugin already requires Maven 2.2.1 (there might be more
>> >> plugins) and that
>> means
>> >> at
>> >> least a Java 1.5 runtime.
>> >>
>> >
>> > Thank you Jörg, in trunk, I added the Maven prerequisites element set
>> > to 2.2.1.
>>
>> Note that this should still allow compilation and testing with Java
>> 1.4 by using the appopriate java profile.
>>
> 
> When I try to use Maven 2.0.11 and Java 1.4.2 for 'mvn clean site' I get:
> 
> [ERROR] BUILD ERROR
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Error resolving version for
> 'org.apache.maven.plugins:maven-assembly-plugin': Plugin requires Maven
> version 2.2.1
> 
> When I try to use Maven 2.2.1 and Java 1.4.2 for 'mvn clean site' I get:
> 
> Java specification version: 1.4
> This release of Maven requires Java version 1.5 or greater.
> 
> So I do not think it is possible any more to build [exec] with anything
> less than Java 5.
> 
> Which is fine by be.

Yes, but you can build with Java 1.4 profile:

mvn -P java-1.4

It depends on your settings.xml which JDK version is used to compile the 
code then:

============== %< ==================
 <profile>
   <id>java-1.4</id>
   <properties>
     <!--JAVA_1_4_HOME>/opt/blackdown-jdk-1.4.2.03</JAVA_1_4_HOME-->
     <JAVA_1_4_HOME>/opt/ibm-jdk-bin-1.4.2.13_p9</JAVA_1_4_HOME>
   </properties>
 </profile>
============== %< ==================

This should work with any Maven version independently of the Java runtime 
used for Maven. However, I did not try it this time.

- Jörg


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message