commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject [NET] Better name for getAddressCountLong() ?
Date Thu, 02 Jan 2014 19:09:31 GMT
There was a problem [1] with the getAddressCount() method - it
returned an int, however the count of addresses could be larger than
Integer.MAX_VALUE.
To preserve binary compat, I added a new method

long getAddressCountLong()

However, I'm not entirely happy with the new name; it seems a bit long
and untidy.

Any suggestions for a new shorter name?

The method [original code: 2] returns the count of availalable
addresses for a given netmask.
[Optionally including the network and broadcast addresses]

[1] https://issues.apache.org/jira/browse/NET-521
[2] http://commons.apache.org/proper/commons-net/xref/org/apache/commons/net/util/SubnetUtils.html#162

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message