commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [compress] 2.0: require Java7?
Date Thu, 02 Jan 2014 14:12:36 GMT
On 2014-01-02, Emmanuel Bourg wrote:

> Le 01/01/2014 23:09, Stefan Bodewig a écrit :

>> AFAIK maven uses some Plexus component which is yet another fork of the
>> codebase originating from Ant - must have been created at about the same
>> time as Compress.

> The forked code has been replaced in plexus-archiver 2.4 with a
> dependency on Commons Compress:

> https://github.com/sonatype/plexus-archiver/commit/ce4bf4c5212188692850f06ee6874196104646e9

Well, not really, plexus-archiver still forks the tar and zip packages,
their choice.  But I get your point.

>> Also we are talking about compress2 which won't be compatible with
>> compress 1.x anyway.

> Sure, but if we stop maintaining compress 1.x that might lead them to
> fork the code again to fix important issues.

TBH I don't expect us to stop maintaining 1.x for bug fixes soon, but
one never knows.

Do you want to ping the Maven folks to see how they feel about it?

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message