commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Bodewig <bode...@apache.org>
Subject Re: [VOTE] Release Compress 1.6 based on RC2
Date Mon, 21 Oct 2013 04:16:32 GMT
On 2013-10-16, Gary Gregory wrote:

> Now that we have a new cleaned up RC, I want to make sure that we
> understand that, strictly speaking and while unlikely in practice,
> 1.6-RC2 breaks binary compatibility with 1.5 (see Clirr). I think we
> started discussing this and after some hand-waving some folks are OK
> with it. I'm not comfortable with it due to getting bitten in large
> integration projects by issues like this and jar hell balls. I'll
> likely defer to the SMEs here but I just want to double check
> specifically on this RC vote thread and hear back before I vote.

Technically this vote has had enough +1s to close it but let me try to
address your concern by repeating and elaborating the alleged
hand-waving:

Clirr whines about a protected field that's been removed from two
classes in the tar package.  The type of this protected field has been
TarBuffer which has been removed, was package private and didn't
implement any interface.  Clirr does not raise an error because of
TarBuffer being removed as it doesn't consider the class a part of the
public API.

The only people who may get bitten by this change must have written
subclasses of one of the Tar*Stream classes and put them into the same
package that we use in order to gain access to a non-public type.

Stefan

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message