commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matt Benson <gudnabr...@gmail.com>
Subject Re: Multimodule site publish
Date Thu, 22 Aug 2013 18:21:16 GMT
Followup:  site:stage gets the directory under "staging" from the
distributionManagement URL.

Matt


On Thu, Aug 22, 2013 at 1:17 PM, Matt Benson <gudnabrsam@gmail.com> wrote:

> The commons-parent POM configures the maven-scm-publish-plugin to take
> content from ${project.reporting.outputDirectory}, typically set to
> target/site.  At least for the MM components, this needs to be something
> like ${project.build.directory}/staging/${commons.componentid}--I'm
> admittedly not sure where the site plugin gets this last directory name.
>  It would seem to be simpler to have one set of site deploy instructions
> for both "simple" and multimodule projects, all of which used site:stage
> and then did the scm-publish from the staging directory.
>
> By way of example, [jci] can't AFAICT be properly deployed with the
> provided instructions either--in fact, its site doesn't even build without
> disabling its overridden maven-project-info-reports plugin settings as well
> as its findbugs-maven-plugin config.
>
> Matt
>
>
> On Thu, Aug 22, 2013 at 7:42 AM, Bruno P. Kinoshita <
> brunodepaulak@yahoo.com.br> wrote:
>
>>
>> Was going to mention that functor's website had the same problem.
>> Building the website locally works fine too.
>>
>> https://issues.apache.org/jira/browse/FUNCTOR-25
>>
>> >________________________________
>> > From: Matt Benson <gudnabrsam@gmail.com>
>> >To: James Carman <james@carmanconsulting.com>
>> >Cc: Commons Developers List <dev@commons.apache.org>
>> >Sent: Thursday, August 22, 2013 9:06 AM
>> >Subject: Re: Multimodule site publish
>> >
>> >
>> >When published. Everything's fine locally. I note the same problem with
>> the
>> >published functor site, though not with JCI. I haven't yet determined
>> what
>> >the difference is, however.
>> >
>> >Matt
>> >On Aug 21, 2013 10:16 PM, "James Carman" <james@carmanconsulting.com>
>> wrote:
>> >
>> >> Didn't come through when published or locally?
>> >>
>> >> On Wednesday, August 21, 2013, Matt Benson wrote:
>> >>
>> >>> Argh, followed instructions at
>> >>> http://commons.apache.org/site-publish.htmlas far as I can tell, but
>> >>> [weaver]'s modules didn't come through.  Do I
>> >>> need to set the commons.scmPubUrl property for each module perhaps?
>> >>>
>> >>> Matt
>> >>>
>> >>
>> >
>> >
>> >
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message