commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benedikt Ritter <brit...@apache.org>
Subject [ALL] Problems with Contiuum (Was: Re: [CHAIN] CHAIN-92 has broken nightly build)
Date Fri, 05 Jul 2013 07:13:55 GMT
Hi,

since I got no replies, I'm moving this to a new thread to get some more
attention ;-)

I'm having a problem with Contiuum. This all started, when I added a new
module to [CHAIN], a test-utils module, that contains code used for testing
used across the other modules.
Shortly after that Contiuum complained that the build was broken [1]. Now
when I click the link to the report [2]I just get an error message:

"javax.jdo.JDODataStoreException: Transaction failed to start
NestedThrowables: com.mysql.jdbc.exceptions.jdbc4.CommunicationsException:
Communications link failure The last packet sent successfully to the server
was 0 milliseconds ago. The driver has not received any packets from the
server."

I thought this may have something to do with my login, so I tried to login
with my LDAP credentials. It didn't work. Next I tried to create a new user
account. But this also failed with an error message.

What is going on? Why does adding a new module break the build? Shouldn't
maven figure this all out? All I can say is that chain test-utils never
made it to the snapshot repo [3].
Any Idea, how to fix this?

TIA
Benedikt

[1] http://markmail.org/thread/xawbqllfe4vwnuij
[2]
http://vmbuild.apache.org/continuum/buildResult.action?buildId=27133&projectId=69
[3]
https://repository.apache.org/content/groups/snapshots/org/apache/commons/

2013/6/20 Benedikt Ritter <britter@apache.org>

>
> 2013/6/18 Benedikt Ritter <beneritter@gmail.com>
>
>> Hi guys,
>>
>> I recently fixed CHAIN-92 [1] but I just realized that I've probably
>> broken the nightly build. From what I can see the new module
>> (commons-chain2-test-utils is not published to the snapshot repository. Can
>> anybody point me to docs what I have to do to enable this? I thought adding
>> a new module in SVN is sufficient. But apparently it isn't :-)
>>
>> Many thanks in advance!
>> Benedikt
>>
>> [1] https://issues.apache.org/jira/browse/CHAIN-92
>
>
> Can someone please verify this?
>
> TIA!
>
>
>
> --
> http://people.apache.org/~britter/
> http://www.systemoutprintln.de/
> http://twitter.com/BenediktRitter
> http://github.com/britter
>



-- 
http://people.apache.org/~britter/
http://www.systemoutprintln.de/
http://twitter.com/BenediktRitter
http://github.com/britter

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message