commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sebb <seb...@gmail.com>
Subject Re: [CP] Error when building CHAIN with CP 31 (Was: Re: [ANNOUNCE] Commons Parent 31 released)
Date Tue, 25 Jun 2013 22:56:46 GMT
And the properties have been changed to the standard maven.compileR.*
(lower case though!)

On 25 June 2013 20:17, Gary Gregory <garydgregory@gmail.com> wrote:
> OT: you should be using Java 7 _25, not _21 ;)
>
> Gary
>
>
> On Tue, Jun 25, 2013 at 3:10 PM, Benedikt Ritter <beneritter@gmail.com>wrote:
>
>> Hi,
>>
>> when building [CHAIN] trunk with:
>>
>> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19
>> 14:51:28+0100)
>> Maven home: /Applications/dev/maven/apache-maven-3.0.5
>> Java version: 1.7.0_21, vendor: Oracle Corporation
>> Java home:
>> /Library/Java/JavaVirtualMachines/jdk1.7.0_21.jdk/Contents/Home/jre
>> Default locale: de_DE, platform encoding: UTF-8
>> OS name: "mac os x", version: "10.8.4", arch: "x86_64", family: "mac"
>>
>> I get:
>>
>> [ERROR] Failed to execute goal
>> org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on
>> project commons-chain-parent: failed to get report for
>> org.apache.maven.plugins:maven-javadoc-plugin: Failed to execute goal
>> org.apache.maven.plugins:maven-compiler-plugin:3.1:compile
>> (default-compile) on project commons-chain2-api: Compilation failure:
>> Compilation failure:
>> [ERROR]
>> /Users/bene/workspace/apache/commons/chain/api/src/main/java/org/apache/commons/chain2/ChainExecutor.java:[30,31]
>> generics are not supported in -source 1.3
>> [ERROR] (use -source 5 or higher to enable generics)
>>
>> maven.compiler.source and maven.compiler.target properties are set to 1.6
>>
>> Any idea what is wrong?
>>
>> Benedikt
>>
>> Am 25.06.2013 um 00:43 schrieb sebb <sebbaz@gmail.com>:
>>
>> > Commons Parent 31 has been released.
>> >
>> > Release notes:
>> >
>> >
>> https://svn.apache.org/repos/asf/commons/proper/commons-parent/tags/commons-parent-31/RELEASE-NOTES.txt
>> >
>> > Components are recommended to upgrade when convenient, but this is not
>> > compulsory.
>> >
>> > If upgrading causes any breaking changes, please report ASAP so a new
>> > release can be prepared.
>> >
>> > ---------------------------------------------------------------------
>> > To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> > For additional commands, e-mail: dev-help@commons.apache.org
>> >
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>>
>
>
> --
> E-Mail: garydgregory@gmail.com | ggregory@apache.org
> Java Persistence with Hibernate, Second Edition<http://www.manning.com/bauer3/>
> JUnit in Action, Second Edition <http://www.manning.com/tahchiev/>
> Spring Batch in Action <http://www.manning.com/templier/>
> Blog: http://garygregory.wordpress.com
> Home: http://garygregory.com/
> Tweet! http://twitter.com/GaryGregory

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message