commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <joerg.schai...@gmx.de>
Subject Re: [IO] converting streams to buffered versions - rename asBufferedxxxx to buffer?`
Date Thu, 16 May 2013 17:13:29 GMT
sebb wrote:

> The issue
> https://issues.apache.org/jira/browse/IO-330
> 
> added 4 methods:
> public static BufferedXXXX asBufferedXXXX(final XXXX xxxx)
> where XXXX = InputStream, OutputStream, Reader, Writer
> 
> I just noticed that
> https://issues.apache.org/jira/browse/IO-233
> suggests overloaded methods called buffer instead:
> 
> public static BufferedXXXX buffer(final XXXX xxxx)
> 
> This is quite a lot easier to type, so I propose to rename the methods
> (and link the JIRAs) unless there are objections.

+1

However, I'd wrap the provided stream/reader/writer only, if it is not 
already a (derived) buffered implementation.

Cheers,
Jörg



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message