commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [pool] 1.x and TestGenericObjectPoolClassLoaders
Date Thu, 16 May 2013 22:30:06 GMT
On 16/05/2013 20:58, Gary Gregory wrote:
> TestGenericObjectPoolClassLoaders (1)
> org.apache.commons.pool.impl.TestGenericObjectPoolClassLoaders
> testContextClassLoader(org.apache.commons.pool.impl.TestGenericObjectPoolClassLoaders)
> junit.framework.AssertionFailedError: Wrong number of idle objects in pool1
> expected:<1> but was:<0>

<snip/>

>     at org.apache.commons.pool.impl.TestGenericObjectPoolClassLoaders.testContextClassLoader(TestGenericObjectPoolClassLoaders.java:46)

<snip/>

Looking at line 46 of the test, it is possible that it could fail
depending on the execution timing. Maybe try increasing the Thread.sleep() ?

> This fails for me from Eclipse and Maven:
> 
> Maven home: C:\Java\apache-maven-3.0.5\bin\..
I don't use Maven.

> Java version: 1.7.0_21, vendor: Oracle Corporation
Same version, 64 bit version.

> Java home: C:\Program Files\Java\jdk1.7.0_21\jre
Different install location - that shouldn't matter.

> Default locale: en_US, platform encoding: Cp1252
en_GB, Cp1252

> OS name: "windows 7", version: "6.1", arch: "amd64", family: "windows"
Same apart from Windows Server 2008 R2

Pretty similar platforms. Best guess is a timing issue.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message