commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Heger <oliver.he...@oliver-heger.de>
Subject Re: [BeanUtils] Update to Java 1.5 for next release?
Date Wed, 06 Mar 2013 20:39:20 GMT
Am 06.03.2013 13:35, schrieb sebb:
> On 6 March 2013 11:32, Benedikt Ritter <britter@apache.org> wrote:
>> Hi,
>>
>> I have recently learned that changing the required Java version for a
>> component does not necessarily affect binary compartibility [1].
>> I'm thinking about updating [BeanUtils] to Java 1.5. We would have the
>> following advantages:
>>
>> - concurrency facilities in java.util.concurrent (could be useful for the
>> internal caching)
>> - generics
>> - JUnit 4
>>
>> WDYT?
>
> +1

+1 from me, too. It really felt strange when creating patches to adhere 
to Java 1.3 restrictions.

Oliver

>
>> Benedikt
>>
>>
>> [1] http://markmail.org/message/mgsjqib5iyyaicgg
>> --
>> http://people.apache.org/~britter/
>> http://www.systemoutprintln.de/
>> http://twitter.com/BenediktRitter
>> http://github.com/britter
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message