commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Meyer" <>
Subject RE: [Math] MATH-894
Date Thu, 15 Nov 2012 13:03:20 GMT
Hi Gilles,

These changes look fine to me and the addition of the compute method is
really nice. Looking more closely at my code, I am using the getElements
method. As long as that remains available, it make sense to deprecate the
getInternalValues method.

My use of ResizeableDoubleArray is related to an earlier discussion -
missing values. My data are stored in a database and it may contain missing
values. I know how many cases are in the database, but I don't know the
amount of missing data. I read the non-missing database values into a
ResizeableDoubleArray, call getElements() and use the nonmissing data array
in my calculations. It may be a bit clunky, but it's one of the ways I
handle missing data without looping over the database twice. I don't have a
solution for comprehensive treatment of missing data yet, but I appreciate
the conversation we are having.


-----Original Message-----
From: Gilles Sadowski [] 
Sent: Thursday, November 15, 2012 6:32 AM
Subject: Re: [Math] MATH-894

Hi Patrick.

On Mon, Nov 12, 2012 at 02:38:07PM -0500, Patrick Meyer wrote:
> Please keep ResizeableDoubleArray as its own class. I find it very 
> useful for more than descriptive statistics. I do like the idea of 
> adding an apply method to it.

Could you please have a look at the JIRA page:
and tell us whether the proposed changes would affect your usage of the

Thanks for the feedback,

> [...]

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message