commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Simone Tripodi <>
Subject Re: [graph] renaming packages
Date Sun, 05 Aug 2012 09:48:02 GMT

> Addition would have signatures like "sum" and "negate", while Multiplication
> would have "multiply" and "invert".
>> What about having Monoid with package visibility and then
>> "Addition/Multiplication... extends Monoid" ?
> Then it would become a bit painless if a class had to implement both
> interfaces (the current "Integer[...]Operations" is an example). I'd just
> have them fully independent from each other, without a common ancestor
> (Monoid).

OK we have an agreement here :) I'll prepare a patch and attach to an
issue to let you review before applying it.

> cool. Class name = "GraphPopulator"? Though it sounds sooo bad to my ears...
> Maybe a mother tongue can help us with the matter :-)

agreed :) Any suggestion? TIA!!!


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message