commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From squar...@dia.uniroma3.it
Subject Re: [graph] renaming packages
Date Fri, 03 Aug 2012 12:39:18 GMT
Hi there :-)

> Hi Claudio!
>
> happy to read from you here :)
>
> I just noticed that the weight/primitives sub-package contains classes
> which name convention refers to *Weight - WDYT renaming them to
> *SumMonoid ?

I am not convinced about this one.
I've come to the conclusion that we should get rid of all the "math-geeky"
vocabulary (monoid is an example) and replace it instead with simpler
names of properties and operations. Really, even people in my lab would be
kind of perplexed with that nomenclature and graphs are already
non-trivial per se ;-)
Also remember that if we ever want to deal with, say, multiplications,
monoids are only going to be in the way (we already touched this topic
before, see [1]). I'm still happy to update and simplify names, only
following a different pattern: e.g. from "DoubleWeightBaseOperations" to
"DoubleOperations". And I'd also replace "Monoid" with "Addition".

After thinking a bit I'm also a bit perplexed about renaming "builder" to
"connect", and in general about the name of the method "connect()". You
know the meaning of "connected" in graph theory, while with our method we
could actually create a graph which is not connected (e.g. one with no
edges at all). So I suggest to look for a less ambiguous alternative:
"populate" (this gets my vote)? "declare"? "construct"? "assemble"?

Cheers from the seaside :-)
Claudio

[1] https://issues.apache.org/jira/browse/SANDBOX-404

>
> best and TIA!
> -Simo
>
> http://people.apache.org/~simonetripodi/
> http://simonetripodi.livejournal.com/
> http://twitter.com/simonetripodi
> http://www.99soft.org/
>
>
> On Thu, Aug 2, 2012 at 12:45 AM,  <squarcel@dia.uniroma3.it> wrote:
>> Hi Simone!
>>
>> Both changes sound good to me. You are more familiar than me with
>> "builder" so I trust your word; and also "s/weight/math" sounds indeed
>> more appropriate given the general purpose classes that it contains.
>>
>> Cheers
>> Claudio
>>
>>> Hi all grap-ers,
>>>
>>> I am doing the n-th review on [graph] and noticed small things could
>>> be improved, such as 2 packages names that IMHO could be improved:
>>>
>>>  * s/builder/connect: nothing that really reflects the builder
>>> pattern, rather a small EDSL to describe graph element connections;
>>>
>>>  * s/weight/math: Monoid and derivates sounds more familiar to a
>>> generic math domain rather than pure weighted edges on graph.
>>>
>>> WDYT?
>>> If there are no objections, I am going to apply that change.
>>>
>>> Many thanks in advance, all the best!
>>> -Simo
>>>
>>> http://people.apache.org/~simonetripodi/
>>> http://simonetripodi.livejournal.com/
>>> http://twitter.com/simonetripodi
>>> http://www.99soft.org/
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>>> For additional commands, e-mail: dev-help@commons.apache.org
>>>
>>>
>>
>>
>> -----------------------------------------
>> This email was sent using SquirrelMail.
>> https://email.dia.uniroma3.it
>> Web Site: http://www.squirrelmail.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
>> For additional commands, e-mail: dev-help@commons.apache.org
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
> For additional commands, e-mail: dev-help@commons.apache.org
>
>


-----------------------------------------
This email was sent using SquirrelMail.
https://email.dia.uniroma3.it
Web Site: http://www.squirrelmail.org


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message