commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Thomas <ma...@apache.org>
Subject Re: [pool] Question / potential improvement on KeyedObjectPool
Date Mon, 30 Jul 2012 21:37:56 GMT
On 30/07/2012 22:33, Gary Gregory wrote:
> On Mon, Jul 30, 2012 at 5:21 PM, Liviu Tudor <liviu.tudor@gmail.com> wrote:
> 
>> Mark/Gary/Seb,
>>
>> Just to clarify this: I haven't touched at all the 1.5 branch -- all of
>> these refer strictly to the 1.6 branch (which uses JDK 1.5 according to
>> the pom and also uses Junit 4.10).
>>
>> So in the light of these, should I:
>>
>> 1/ also apply these patches to the 1.5 branch?
>>
> 
> Up to you.
> 
> 
>> 2/ downgrade junit to 3.8.2 on the 1.6 branch?
>>
> 
> I do not think so, this branch is for Java >= 1.5. Why? Does JUnit 4.10 not
> run on Java 5?

1.6.x is meant to be 1.5.x plus generics. The more they diverge, the
harder they will be to keep in sync.

Mark


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@commons.apache.org
For additional commands, e-mail: dev-help@commons.apache.org


Mime
View raw message