commons-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gilles Sadowski <>
Subject Re: [math] API proposal for differentiation
Date Mon, 23 Jul 2012 10:11:23 GMT

> [...]
> > 
> > Maybe yet another name: I don't understand "DifferentialPair" either.
> It simply depicts the content of this small container: two fields, f0
> for the value, f1 for the first derivative.

That much I figured out. :-)
What I meant is that the name "DifferentialPair" does not exactly make this
contents obvious. To be fully descriptive, it should be something like
"ValueAndDerivativePair". However, we could maybe come up with something
shorter, and that would remind its purpose, not just its contents. Or maybe
just the purpose, as it's not likely that such a container will be used for
something else; i.e. "RallNumber" or "AutoDiffPair" would be fine.
But the naming should also be easily extensible to multivariate and vector

> [...]
> I slightly tend to prefer the aggregation. [...]

If you thinks that it makes more sense, that's fine then.

> [...]


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message